Rider University - Telephone System Outage – Incident details

Telephone System Outage

Resolved
Operational
Started about 1 year agoLasted about 11 hours

Affected

Phone System

Operational from 4:21 PM to 3:19 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    The Rider University Telephone System is currently down. Our Telephony provider is currently troubleshooting the issue.